What’s Vulnerable › Vulnerabilities
CVE-2025-1774: Logs manipulation in BotSense
- Severity: medium (CVSS 6.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-17 · updated 2026-06-17
- Weakness: CWE-142
Description
Incorrect string encoding vulnerability in NASK - PIB BotSense allows injection of an additional field separator character or value in the content of some fields of the generated event. A field with additional field separator characters or values can be included in the "extraData" field.This issue affects BotSense in versions before 2.8.0.
Affected products
- NASK - PIB BotSense: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: NASK - PIB BotSense 2.8.0. Check the vendor advisory for mitigations.
References
- https://cert.pl/en/posts/2025/03/CVE-2025-1774/
- https://cert.pl/posts/2025/03/CVE-2025-1774/
- https://nask.pl/instytut/dla-biznesu/botsense/
Get alerted when CVE-2025-1774 or the next vulnerability affects your stack