What’s Vulnerable › Vulnerabilities
CVE-2025-1776: Cross-Site Scripting (XSS) vulnerability in Soteshop
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-Site Scripting (XSS) vulnerability in Soteshop, versions prior to 8.3.4, which could allow remote attackers to execute arbitrary code via the ‘query’ parameter in /app-google-custom-search/searchResults. This vulnerability can be exploited to steal sensitive user data, such as session cookies, or to perform actions on behalf of the user.
Affected products
- Soteshop: before 8.3.4 — fixed in 8.3.4
How to fix
Upgrade to a fixed version: Soteshop 8.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1776 or the next vulnerability affects your stack