What’s Vulnerable › Vulnerabilities
CVE-2025-1783: Gallery Styles <= 1.3.4 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gallery Styles plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Gallery Block in all versions up to, and including, 1.3.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- kometschuh Gallery Styles: before 1.3.5 — fixed in 1.3.5
How to fix
Upgrade to a fixed version: kometschuh Gallery Styles 1.3.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/gallery-styles/tags/1.3.4/gallery-styles.php#L34
- https://plugins.trac.wordpress.org/changeset/3251908/gallery-styles/trunk/gallery-styles.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c9443e36-648c-4984-8b06-28e9da959e26?source=cve
Get alerted when CVE-2025-1783 or the next vulnerability affects your stack