What’s Vulnerable › Vulnerabilities
CVE-2025-1785: Download Manager <= 3.3.08 - Authenticated (Author+) Path Traversal to Limited File Overwrite
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-13 · updated 2026-06-17
- Weakness: CWE-22
Description
The Download Manager plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 3.3.08 via the 'wpdm_newfile' action. This makes it possible for authenticated attackers, with Author-level access and above, to overwrite select file types outside of the originally intended directory, which may cause a denial of service.
Affected products
- codename065 Download Manager: before 3.3.09 — fixed in 3.3.09
How to fix
Upgrade to a fixed version: codename065 Download Manager 3.3.09. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3252990%40download-manager&new=3252990%40download-manager&sfp_email=&sfph_mail=#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bc5c7974-4c10-4880-8823-2accee3c0da4?source=cve
Get alerted when CVE-2025-1785 or the next vulnerability affects your stack