What’s Vulnerable › Vulnerabilities

CVE-2025-1792: Improper Access Control in Mattermost Channel Member API

Description

Mattermost versions 10.7.x <= 10.7.0, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to properly enforce access controls for guest users accessing channel member information, allowing authenticated guest users to view metadata about members of public channels via the channel members API endpoint.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.5.4, 10.7.1, 9.11.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-1792 or the next vulnerability affects your stack