What’s Vulnerable › Vulnerabilities
CVE-2025-1793: SQL Injection in run-llama/llama_index
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-05 · updated 2026-06-17
- Weakness: CWE-89
Description
Multiple vector store integrations in run-llama/llama_index version v0.12.21 have SQL injection vulnerabilities. These vulnerabilities allow an attacker to read and write data using SQL, potentially leading to unauthorized access to data of other users depending on the usage of the llama-index library in a web application.
Affected products
- run-llama/llama_index: from 0.12.21 before 0.12.28 — fixed in 0.12.28
How to fix
Upgrade to a fixed version: run-llama/llama_index 0.12.28. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama_index/commit/0008041e8dde8e519621388e5d6f558bde6ef42e
- https://huntr.com/bounties/8cb1555a-9655-4122-b0d6-60059e79183c
- https://huntr.com/bounties/8cb1555a-9655-4122-b0d6-60059e79183c
Get alerted when CVE-2025-1793 or the next vulnerability affects your stack