What’s Vulnerable › Vulnerabilities
CVE-2025-1908: Business Logic Errors in GitLab
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-24 · updated 2026-06-17
- Weakness: CWE-840
Description
An issue has been discovered in GitLab EE/CE that could allow an attacker to track users' browsing activities, potentially leading to full account take-over, affecting all versions from 16.6 before 17.9.7, 17.10 before 17.10.5, and 17.11 before 17.11.1.
Affected products
- GitLab: from 16.6.0 before 17.9.7; from 17.10.0 before 17.10.5; 17.11.0 — fixed in 17.10.5, 17.9.7
How to fix
Upgrade to a fixed version: GitLab 17.10.5, 17.9.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1908 or the next vulnerability affects your stack