What’s Vulnerable › Vulnerabilities
CVE-2025-1909: BuddyBoss Platform Pro <= 2.7.01 - Authentication Bypass via Apple OAuth provider
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-05 · updated 2026-06-17
- Weakness: CWE-288
Description
The BuddyBoss Platform Pro plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.7.01. This is due to insufficient verification on the user being supplied during the Apple OAuth authenticate request through the plugin. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email.
Affected products
- Boss Media BuddyBoss Platform: before 2.7.10 — fixed in 2.7.10
How to fix
Upgrade to a fixed version: Boss Media BuddyBoss Platform 2.7.10. Check the vendor advisory for mitigations.
References
- https://www.buddyboss.com/resources/buddyboss-platform-pro-releases/
- https://www.buddyboss.com/resources/buddyboss-platform-pro-releases/2-7-10/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7cce9b8b-0589-4b09-b184-a66fc86fcb46?source=cve
Get alerted when CVE-2025-1909 or the next vulnerability affects your stack