What’s Vulnerable › Vulnerabilities
CVE-2025-1912: Product Import Export for WooCommerce <= 2.5.0 - Authenticated (Administrator+) Server-Side Request Forgery via validate_file Function
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-918
Description
The Product Import Export for WooCommerce – Import Export Product CSV Suite plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.5.0 via the validate_file() Function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- webtoffee Product Import Export for WooCommerce – Import Export Product CSV Suite: before 2.5.1 — fixed in 2.5.1
How to fix
Upgrade to a fixed version: webtoffee Product Import Export for WooCommerce – Import Export Product CSV Suite 2.5.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/product-import-export-for-woo/trunk/admin/modules/import/classes/class-import-ajax.php#L175
- https://plugins.trac.wordpress.org/changeset/3261194/
- https://wordpress.org/plugins/product-import-export-for-woo/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/406b52dc-3d36-4b03-a932-34f456395979?source=cve
Get alerted when CVE-2025-1912 or the next vulnerability affects your stack