What’s Vulnerable › Vulnerabilities
CVE-2025-1926: Page Builder: Pagelayer – Drag and Drop website builder <= 1.9.8 - Cross-Site Request Forgery (CSRF) To Post Contents Modification
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-10 · updated 2026-06-17
- Weakness: CWE-352
Description
The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.9.8. This is due to missing or incorrect nonce validation on the pagelayer_save_post function. This makes it possible for unauthenticated attackers to modify post contents via a forged request, granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- softaculous Page Builder: Pagelayer – Drag and Drop website builder: before 1.9.9 — fixed in 1.9.9
How to fix
Upgrade to a fixed version: softaculous Page Builder: Pagelayer – Drag and Drop website builder 1.9.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/pagelayer/tags/1.9.8/init.php#L477
- https://www.wordfence.com/threat-intel/vulnerabilities/id/542b6312-b264-49d5-882a-454427c60c8a?source=cve
Get alerted when CVE-2025-1926 or the next vulnerability affects your stack