What’s Vulnerable › Vulnerabilities
CVE-2025-1970: Export and Import Users and Customers <= 2.6.2 - Authenticated (Administrator+) Server-Side Request Forgery via validate_file Function
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-22 · updated 2026-06-17
- Weakness: CWE-918
Description
The Export and Import Users and Customers plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.6.2 via the validate_file() function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- webtoffee Export and Import Users and Customers: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: webtoffee Export and Import Users and Customers 2.6.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/users-customers-import-export-for-wp-woocommerce/trunk/admin/modules/import/classes/class-import-ajax.php#L175
- https://plugins.trac.wordpress.org/changeset/3259688/
- https://wordpress.org/plugins/users-customers-import-export-for-wp-woocommerce/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5a4d7d40-8e0e-4251-8e25-3fd4ebd3a93e?source=cve
Get alerted when CVE-2025-1970 or the next vulnerability affects your stack