What’s Vulnerable › Vulnerabilities
CVE-2025-1972: Export and Import Users and Customers <= 2.6.2 - Directory Traversal to Authenticated (Administrator+) Limited Arbitrary File Deletion via admin_log_page Function
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-22 · updated 2026-06-17
- Weakness: CWE-73
Description
The Export and Import Users and Customers plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the admin_log_page() function in all versions up to, and including, 2.6.2. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete arbitrary log files on the server.
Affected products
- webtoffee Export and Import Users and Customers: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: webtoffee Export and Import Users and Customers 2.6.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/users-customers-import-export-for-wp-woocommerce/trunk/admin/modules/history/history.php#L248
- https://plugins.trac.wordpress.org/changeset/3259688/
- https://wordpress.org/plugins/users-customers-import-export-for-wp-woocommerce/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2d443c70-6537-4c6d-a282-12d392f0f558?source=cve
Get alerted when CVE-2025-1972 or the next vulnerability affects your stack