What’s Vulnerable › Vulnerabilities
CVE-2025-1979
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-06 · updated 2026-06-17
- Weakness: CWE-532
Description
Versions of the package ray before 2.43.0 are vulnerable to Insertion of Sensitive Information into Log File where the redis password is being logged in the standard logging. If the redis password is passed as an argument, it will be logged and could potentially leak the password. This is only exploitable if: 1) Logging is enabled; 2) Redis is using password authentication; 3) Those logs are accessible to an attacker, who can reach that redis instance. **Note:** It is recommended that anyone who is running in this configuration should update to the latest version of Ray, then rotate their redis password.
Affected products
- ray: before 2.43.0 — fixed in 2.43.0
How to fix
Upgrade to a fixed version: ray 2.43.0. Check the vendor advisory for mitigations.
References
- https://github.com/ray-project/ray/commit/64a2e4010522d60b90c389634f24df77b603d85d
- https://github.com/ray-project/ray/issues/50266
- https://github.com/ray-project/ray/pull/50409
- https://security.snyk.io/vuln/SNYK-PYTHON-RAY-8745212
Get alerted when CVE-2025-1979 or the next vulnerability affects your stack