What’s Vulnerable › Vulnerabilities
CVE-2025-2000: Qiskit SDK code execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-14 · updated 2026-06-17
- Weakness: CWE-502
Description
A maliciously crafted QPY file can potential execute arbitrary-code embedded in the payload without privilege escalation when deserialising QPY formats < 13. A python process calling Qiskit 0.18.0 through 1.4.1's `qiskit.qpy.load()` function could potentially execute any arbitrary Python code embedded in the correct place in the binary file as part of specially constructed payload.
Affected products
- IBM Qiskit SDK: from 0.18.0 before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: IBM Qiskit SDK 1.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2000 or the next vulnerability affects your stack