What’s Vulnerable › Vulnerabilities

CVE-2025-20033: DoS via custom post type for sysconsole plugin readers

Description

Mattermost versions 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post types, which allows attackers to deny service to users with the sysconsole_read_plugins permission via creating a post with the custom_pl_notification type and specific props.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.0.4, 10.1.4, 10.2.1, 9.11.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-20033 or the next vulnerability affects your stack