What’s Vulnerable › Vulnerabilities

CVE-2025-20086: Insufficient Input Validation on Post Props

Description

Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post props which allows a malicious authenticated user to cause a crash via a malicious post.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.0.4, 10.1.4, 9.11.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-20086 or the next vulnerability affects your stack