What’s Vulnerable › Vulnerabilities
CVE-2025-20088: Insufficient Input Validation on Post Props
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-15 · updated 2026-06-17
- Weakness: CWE-1287
Description
Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post props which allows a malicious authenticated user to cause a crash via a malicious post.
Affected products
- Mattermost: from 9.11.0 before 9.11.6; from 10.0.0 before 10.0.4; from 10.1.0 before 10.1.4; 10.2.0 — fixed in 10.0.4, 10.1.4, 9.11.6
How to fix
Upgrade to a fixed version: Mattermost 10.0.4, 10.1.4, 9.11.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20088 or the next vulnerability affects your stack