What’s Vulnerable › Vulnerabilities
CVE-2025-20123: Cisco Crosswork Network Controller Stored Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple vulnerabilities in the web-based management interface of Cisco Crosswork Network Controller could allow an authenticated, remote attacker to conduct cross-site scripting (XSS) attacks against users of the interface of an affected system. These vulnerabilities exist because the web-based management interface does not properly validate user-supplied input. An attacker could exploit these vulnerabilities by inserting malicious data into specific data fields in the interface. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. To exploit these vulnerabilities, the attacker must have valid administrative credentials. Cisco has released software updates that address these vulnerabilities. There are no workarounds that address these vulnerabilities.
Affected products
- Cisco Crosswork Network Change Automation: from 5.0.0 before 5.0.4; from 6.0.0 before 6.0.3; from 7.0.0 before 7.0.1 — fixed in 5.0.4, 6.0.3, 7.0.1
How to fix
Upgrade to a fixed version: Cisco Crosswork Network Change Automation 5.0.4, 6.0.3, 7.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20123 or the next vulnerability affects your stack