What’s Vulnerable › Vulnerabilities
CVE-2025-20124: Cisco Identity Services Engine Java Deserialization Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-05 · updated 2026-06-17
- Weakness: CWE-502
Description
A vulnerability in an API of Cisco ISE could allow an authenticated, remote attacker to execute arbitrary commands as the root user on an affected device. This vulnerability is due to insecure deserialization of user-supplied Java byte streams by the affected software. An attacker could exploit this vulnerability by sending a crafted serialized Java object to an affected API. A successful exploit could allow the attacker to execute arbitrary commands on the device and elevate privileges. Note: To successfully exploit this vulnerability, the attacker must have valid read-only administrative credentials. In a single-node deployment, new devices will not be able to authenticate during the reload time.
Affected products
- Cisco Identity Services Engine: before 3.1; 3.1.0, 3.1.0-patch1, 3.1.0-patch2, 3.1.0-patch3, 3.1.0-patch4, 3.1.0-patch5 (+15) — fixed in 3.1
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20124 or the next vulnerability affects your stack