What’s Vulnerable › Vulnerabilities
CVE-2025-20126: Cisco ThousandEyes Endpoint Agent Certificate Validation Vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-295
Description
A vulnerability in certification validation routines of Cisco ThousandEyes Endpoint Agent for macOS and RoomOS could allow an unauthenticated, remote attacker to intercept or manipulate metrics information. This vulnerability exists because the affected software does not properly validate certificates for hosted metrics services. An on-path attacker could exploit this vulnerability by intercepting network traffic using a crafted certificate. A successful exploit could allow the attacker to masquerade as a trusted host and monitor or change communications between the remote metrics service and the vulnerable client.
Affected products
- Cisco ThousandEyes Endpoint Agent: before 1.206.3; before 1.207.2 — fixed in 1.206.3, 1.207.2
How to fix
Upgrade to a fixed version: Cisco ThousandEyes Endpoint Agent 1.206.3, 1.207.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20126 or the next vulnerability affects your stack