What’s Vulnerable › Vulnerabilities
CVE-2025-20128: ClamAV OLE2 File Format Decryption Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-22 · updated 2026-06-17
- Weakness: CWE-122
Description
A vulnerability in the Object Linking and Embedding 2 (OLE2) decryption routine of ClamAV could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. This vulnerability is due to an integer underflow in a bounds check that allows for a heap buffer overflow read. An attacker could exploit this vulnerability by submitting a crafted file containing OLE2 content to be scanned by ClamAV on an affected device. A successful exploit could allow the attacker to terminate the ClamAV scanning process, resulting in a DoS condition on the affected software. For a description of this vulnerability, see the . Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.
Affected products
- Cisco Secure Endpoint: before 1.24.4; before 1.25.1; before 7.5.20; from 8.0.1.21160 before 8.4.3 — fixed in 1.24.4, 1.25.1, 7.5.20, 8.4.3
- Cisco Secure Endpoint Private Cloud: before 4.2.0 — fixed in 4.2.0
- Cisco ClamAV: from 1.0.0 before 1.0.8; from 1.1.0 before 1.4.2 — fixed in 1.0.8, 1.4.2
How to fix
Upgrade to a fixed version: Cisco Secure Endpoint 1.24.4, 1.25.1, 7.5.20, 8.4.3; Cisco Secure Endpoint Private Cloud 4.2.0; Cisco ClamAV 1.0.8, 1.4.2. Check the vendor advisory for mitigations.
References
- https://blog.clamav.net/2025/01/clamav-142-and-108-security-patch.html
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-clamav-ole2-H549rphA
- https://lists.debian.org/debian-lts-announce/2025/09/msg00006.html
Get alerted when CVE-2025-20128 or the next vulnerability affects your stack