What’s Vulnerable › Vulnerabilities
CVE-2025-20138: Cisco IOS XR Software CLI Privilege Escalation Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the CLI of Cisco IOS XR Software could allow an authenticated, local attacker to execute arbitrary commands as root on the underlying operating system of an affected device. This vulnerability is due to insufficient validation of user arguments that are passed to specific CLI commands. An attacker with a low-privileged account could exploit this vulnerability by using crafted commands at the prompt. A successful exploit could allow the attacker to elevate privileges to root and execute arbitrary commands.
Affected products
- Cisco IOS XR Software: before 24.2.21; from 24.3 before 24.4 — fixed in 24.2.21, 24.4
How to fix
Upgrade to a fixed version: Cisco IOS XR Software 24.2.21, 24.4. Check the vendor advisory for mitigations.
References
- https://blog.apnic.net/2024/09/02/crafting-endless-as-paths-in-bgp/
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-iosxr-priv-esc-GFQjxvOF
Get alerted when CVE-2025-20138 or the next vulnerability affects your stack