What’s Vulnerable › Vulnerabilities
CVE-2025-20166: Cisco Common Services Platform Collector Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-86
Description
A vulnerability in the web-based management interface of Cisco Common Services Platform Collector (CSPC) could allow an authenticated, remote attacker to conduct cross-site scripting (XSS) attacks against a user of the interface. This vulnerability is due to insufficient validation of user-supplied input by the web-based management interface of an affected system. An attacker could exploit this vulnerability by injecting malicious code into specific pages of the interface. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. To exploit this vulnerability, the attacker must have at least a low-privileged account on an affected device. Cisco has not released software updates that address this vulnerability. There are no workarounds that address this vulnerability.
Affected products
- Cisco Common Services Platform Collector Software: 2.11, 2.11.0.1, 2.11.0.2, 2.11.0.3, 30.1.1-0
- Cisco Crosswork Network Change Automation: from 5.0.0 before 5.0.4; from 6.0.0 before 6.0.3; from 7.0.0 before 7.0.1 — fixed in 5.0.4, 6.0.3, 7.0.1
How to fix
Upgrade to a fixed version: Cisco Crosswork Network Change Automation 5.0.4, 6.0.3, 7.0.1. Check the vendor advisory for mitigations.
References
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cspc-xss-CDOJZyH
- https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-xwork-xss-KCcg7WwU
Get alerted when CVE-2025-20166 or the next vulnerability affects your stack