What’s Vulnerable › Vulnerabilities
CVE-2025-20205
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-05 · updated 2026-07-21
- Weakness: CWE-79
Description
Multiple vulnerabilities in the web-based management interface of Cisco Identity Services Engine (ISE) guest portals could allow an authenticated, remote attacker to conduct cross-site scripting (XSS) attacks against a user of the interface. These vulnerabilities are due to insufficient validation of user-supplied input by the web-based management interface of an affected system. An attacker could exploit these vulnerabilities by injecting malicious code into specific pages of the interface. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. To exploit these vulnerabilities, the attacker must have valid administrative credentials.
Affected products
- Cisco Identity Services Engine: from 3.0.0 before 3.2; 3.2.0, 3.2.0-patch1, 3.2.0-patch2, 3.2.0-patch3, 3.2.0-patch4, 3.2.0-patch5 (+6) — fixed in 3.2
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20205 or the next vulnerability affects your stack