What’s Vulnerable › Vulnerabilities
CVE-2025-20226: Risky command safeguards bypass in “/services/streams/search“ endpoint through “q“ parameter in Splunk Enterprise
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-200
Description
In Splunk Enterprise versions below 9.4.1, 9.3.3, 9.2.5, and 9.1.8 and Splunk Cloud Platform versions below 9.3.2408.107, 9.2.2406.111, and 9.1.2308.214, a low-privileged user that does not hold the "admin" or "power" Splunk roles could run a saved search with a risky command using the permissions of a higher-privileged user to bypass the SPL safeguards for risky commands on the "/services/streams/search" endpoint through its "q" parameter. The vulnerability requires the attacker to phish the victim by tricking them into initiating a request within their browser. The authenticated user should not be able to exploit the vulnerability at will.
Affected products
- Splunk Enterprise: from 9.1.0 before 9.1.8; from 9.2.0 before 9.2.5; from 9.3.0 before 9.3.3; 9.4.0 — fixed in 9.1.8, 9.2.5, 9.3.3
- Splunk Cloud Platform: from 9.1.2308 before 9.1.2308.214; from 9.2.2406.100 before 9.2.2406.111; from 9.3.2408.100 before 9.3.2408.107 — fixed in 9.1.2308.214, 9.2.2406.111, 9.3.2408.107
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.1.8, 9.2.5, 9.3.3; Splunk Cloud Platform 9.1.2308.214, 9.2.2406.111, 9.3.2408.107. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20226 or the next vulnerability affects your stack