What’s Vulnerable › Vulnerabilities

CVE-2025-20231: Sensitive Information Disclosure in Splunk Secure Gateway App

Description

In Splunk Enterprise versions below 9.4.1, 9.3.3, 9.2.5, and 9.1.8, and versions below 3.8.38 and 3.7.23 of the Splunk Secure Gateway app on Splunk Cloud Platform, a low-privileged user that does not hold the “admin“ or “power“ Splunk roles could run a search using the permissions of a higher-privileged user that could lead to disclosure of sensitive information.<br><br>The vulnerability requires the attacker to phish the victim by tricking them into initiating a request within their browser. The authenticated low-privileged user should not be able to exploit the vulnerability at will.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.1.8, 9.2.5, 9.3.3; Splunk Secure Gateway 3.7.23, 3.8.38. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-20231 or the next vulnerability affects your stack