What’s Vulnerable › Vulnerabilities
CVE-2025-20267: Cisco Identity Services Stored Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-21 · updated 2026-06-17
- Weakness: CWE-80
Description
A vulnerability in the web-based management interface of Cisco Identity Services Engine (ISE) could allow an authenticated, remote attacker to conduct cross-site scripting (XSS) attacks against a user of the interface. This vulnerability is due to insufficient validation of user-supplied input by the web-based management interface of an affected system. An attacker could exploit this vulnerability by injecting malicious code into specific pages of the interface. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. To exploit this vulnerability, the attacker must have valid administrative credentials.
Affected products
- Cisco Identity Services Engine: before 3.2.0; 3.2.0, 3.2.0-patch1, 3.2.0-patch2, 3.2.0-patch3, 3.2.0-patch4, 3.2.0-patch5 (+8) — fixed in 3.2.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20267 or the next vulnerability affects your stack