What’s Vulnerable › Vulnerabilities
CVE-2025-20270: Cisco Evolved Programmable Network Manager Information Disclosure Vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-03 · updated 2026-10-18
- Weakness: CWE-200
Description
A vulnerability in the web-based management interface of Cisco Evolved Programmable Network Manager (EPNM) and Cisco Prime Infrastructure could allow an authenticated, remote attacker to obtain sensitive information from an affected system. This vulnerability is due to improper validation of requests to API endpoints. An attacker could exploit this vulnerability by sending a valid request to a specific API endpoint within the affected system. A successful exploit could allow a low-privileged user to view sensitive configuration information on the affected system that should be restricted. To exploit this vulnerability, an attacker must have access as a low-privileged user.
Affected products
- Cisco Evolved Programmable Network Manager (EPNM): through 7.1.0; from 8.0.0 before 8.0.1; from 8.1.0 before 8.1.2 — fixed in 8.0.1, 8.1.2
- Cisco Prime Infrastructure: through 3.9; from 3.10 through 3.10.6
How to fix
Upgrade to a fixed version: Cisco Evolved Programmable Network Manager (EPNM) 8.0.1, 8.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20270 or the next vulnerability affects your stack