What’s Vulnerable › Vulnerabilities
CVE-2025-20272: Cisco Evolved Programmable Network Manager and Cisco Prime Infrastructure Blind SQL Injection Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-16 · updated 2026-06-29
- Weakness: CWE-89
Description
A vulnerability in a subset of REST APIs of Cisco Prime Infrastructure and Cisco Evolved Programmable Network Manager (EPNM) could allow an authenticated, low-privileged, remote attacker to conduct a blind SQL injection attack. This vulnerability is due to insufficient validation of user-supplied input. An attacker could exploit this vulnerability by sending a crafted request to an affected API. A successful exploit could allow the attacker to view data in some database tables on an affected device.
Affected products
- Cisco Evolved Programmable Network Manager (EPNM): before 8.0.1; 8.1.0 — fixed in 8.0.1
- Cisco Prime Infrastructure: before 3.10.6; 3.10.6, 3.10.6-security_update_01 — fixed in 3.10.6
How to fix
Upgrade to a fixed version: Cisco Evolved Programmable Network Manager (EPNM) 8.0.1; Cisco Prime Infrastructure 3.10.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20272 or the next vulnerability affects your stack