What’s Vulnerable › Vulnerabilities
CVE-2025-20278: Cisco Unified Communications Products Command Injection Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-04 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the CLI of multiple Cisco Unified Communications products could allow an authenticated, local attacker to execute arbitrary commands on the underlying operating system of an affected device as the root user. This vulnerability is due to improper validation of user-supplied command arguments. An attacker could exploit this vulnerability by executing crafted commands on the CLI of an affected device. A successful exploit could allow the attacker to execute arbitrary commands on the underlying operating system of an affected device as the root user. To exploit this vulnerability, the attacker must have valid administrative credentials.
Affected products
- Cisco Finesse: 10.5(1), 10.5(1)_es1, 10.5(1)_es2, 10.5(1)_es3, 10.5(1)_es4, 10.5(1)_es5 (+75)
- Cisco SocialMiner: 10.5(1), 10.6(1), 10.6(2), 11.0(1), 11.5(1), 11.5(1)su1 (+11)
- Cisco Unified Communications Manager: 12.5(1), 12.5(1)su1, 12.5(1)su2, 12.5(1)su3, 12.5(1)su4, 12.5(1)su5 (+6)
- Cisco Unified Communications Manager IM and Presence Service: 12.5(1), 12.5(1)su1, 12.5(1)su2, 12.5(1)su3, 12.5(1)su4, 12.5(1)su5 (+4)
- Cisco Unified Contact Center Express: 8.5(1), 9.0(2)su3es04, 10.0(1)su1, 10.0(1)su1es04, 10.5(1), 10.5(1)su1 (+54)
- Cisco Unified Intelligence Center: before 12.6\(2\)es_04 — fixed in 12.6\(2\)es_04
- Cisco Unity Connection: 12.5(1), 12.5(1)su1, 12.5(1)su2, 12.5(1)su3, 12.5(1)su4, 12.5(1)su5 (+5)
- Cisco Virtualized Voice Browser: before 12.6\(2\)es06 — fixed in 12.6\(2\)es06
How to fix
Upgrade to a fixed version: Cisco Unified Intelligence Center 12.6\(2\)es_04; Cisco Virtualized Voice Browser 12.6\(2\)es06. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20278 or the next vulnerability affects your stack