What’s Vulnerable › Vulnerabilities
CVE-2025-20283: Cisco Identity Services Engine Authenticated Remote Code Execution Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-16 · updated 2026-06-17
- Weakness: CWE-74
Description
A vulnerability in a specific API of Cisco ISE and Cisco ISE-PIC could allow an authenticated, remote attacker to execute arbitrary code on the underlying operating system as root. This vulnerability is due to insufficient validation of user-supplied input. An attacker with valid credentials could exploit this vulnerability by submitting a crafted API request. A successful exploit could allow the attacker to execute commands as the root user. To exploit this vulnerability, the attacker must have valid high-privileged credentials.
Affected products
- Cisco Identity Services Engine: before 3.3.0; 3.3.0, 3.3.0-patch1, 3.3.0-patch2, 3.3.0-patch3, 3.3.0-patch4, 3.3.0-patch5 (+3) — fixed in 3.3.0
- Cisco Identity Services Engine Passive Identity Connector: before 3.3.0; 3.3.0, 3.3.0-patch1, 3.3.0-patch2, 3.3.0-patch3, 3.3.0-patch4, 3.3.0-patch5 (+3) — fixed in 3.3.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.3.0; Cisco Identity Services Engine Passive Identity Connector 3.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20283 or the next vulnerability affects your stack