What’s Vulnerable › Vulnerabilities
CVE-2025-20296: Cisco UCS Manager Software Stored Software Stored Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-27 · updated 2026-09-18
- Weakness: CWE-79
Description
A vulnerability in the web-based management interface of Cisco UCS Manager Software could allow an authenticated, remote attacker to conduct a stored cross-site scripting (XSS) attack against a user of the interface. This vulnerability is due to insufficient validation of user-supplied input by the web-based management interface of an affected system. An attacker could exploit this vulnerability by injecting malicious data into specific pages of the interface. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. To exploit this vulnerability, the attacker must be a member of the Administrator or AAA Administrator role.
Affected products
- Cisco Ucs Manager: before 4.2\(3p\); from 4.3\(2b\) before 4.3\(6a\) — fixed in 4.2\(3p\), 4.3\(6a\)
How to fix
Upgrade to a fixed version: Cisco Ucs Manager 4.2\(3p\), 4.3\(6a\). Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20296 or the next vulnerability affects your stack