What’s Vulnerable › Vulnerabilities

CVE-2025-20297: Reflected Cross-Site Scripting (XSS) on Splunk Enterprise through dashboard PDF generation component

Description

In Splunk Enterprise versions below 9.4.2, 9.3.4 and 9.2.6, and Splunk Cloud Platform versions below 9.3.2411.102, 9.3.2408.111 and 9.2.2406.118, a low-privileged user that does not hold the "admin" or "power" Splunk roles could craft a malicious payload through the pdfgen/render REST endpoint that could result in execution of unauthorized JavaScript code in the browser of a user.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.2.6, 9.3.4, 9.4.2; Splunk Cloud Platform 9.2.2406.118, 9.3.2408.111, 9.3.2411.102. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-20297 or the next vulnerability affects your stack