What’s Vulnerable › Vulnerabilities

CVE-2025-20300: Improper Access Control Lets Low-Privilege Users Suppress Read-Only Alerts in Splunk Enterprise

Description

In Splunk Enterprise versions below 9.4.2, 9.3.5, 9.2.6, and 9.1.9 and Splunk Cloud Platform versions below 9.3.2411.103, 9.3.2408.112, and 9.2.2406.119, a low-privileged user that does not hold the "admin" or "power" Splunk roles, and has read-only access to a specific alert, could suppress that alert when it triggers. See [Define alert suppression groups to throttle sets of similar alerts](https://help.splunk.com/en/splunk-enterprise/alert-and-respond/alerting-manual/9.4/manage-alert-trigger-conditions-and-throttling/define-alert-suppression-groups-to-throttle-sets-of-similar-alerts).

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.1.9, 9.2.6, 9.3.5, 9.4.2; Splunk Cloud Platform 9.2.2406.118, 9.3.2408.112, 9.3.2411.103. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-20300 or the next vulnerability affects your stack