What’s Vulnerable › Vulnerabilities
CVE-2025-20320: Denial of Service (DoS) through “User Interface - Views“ configuration page in Splunk Enterprise
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-35
Description
In Splunk Enterprise versions below 9.4.3, 9.3.5, 9.2.7 and 9.1.10, and Splunk Cloud Platform versions below 9.3.2411.107, 9.3.2408.117, and 9.2.2406.121, a low-privileged user that does not hold the "admin" or "power" Splunk roles could craft a malicious payload through the `User Interface - Views` configuration page that could potentially lead to a denial of service (DoS).The user could cause the DoS by exploiting a path traversal vulnerability that allows for deletion of arbitrary files within a Splunk directory. The vulnerability requires the low-privileged user to phish the administrator-level victim by tricking them into initiating a request within their browser. The low-privileged user should not be able to exploit the vulnerability at will.
Affected products
- Splunk Enterprise: from 9.1.0 before 9.1.10; from 9.2.0 before 9.2.7; from 9.3.0 before 9.3.5; from 9.4.0 before 9.4.3 — fixed in 9.1.10, 9.2.7, 9.3.5, 9.4.3
- Splunk Cloud Platform: from 9.2.2406 before 9.2.2406.121; from 9.3.2408 before 9.3.2408.117; from 9.3.2411 before 9.3.2411.107 — fixed in 9.2.2406.121, 9.3.2408.117, 9.3.2411.107
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.1.10, 9.2.7, 9.3.5, 9.4.3; Splunk Cloud Platform 9.2.2406.121, 9.3.2408.117, 9.3.2411.107. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20320 or the next vulnerability affects your stack