What’s Vulnerable › Vulnerabilities
CVE-2025-20349: Cisco DNA Center API Command Injection Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-13 · updated 2026-10-07
- Weakness: CWE-78
Description
A vulnerability in the REST API of Cisco Catalyst Center could allow an authenticated, remote attacker to execute arbitrary commands in a restricted container as the root user. This vulnerability is due to insufficient validation of user-supplied input in REST API request parameters. An attacker could exploit this vulnerability by sending a crafted API request to an affected device. A successful exploit could allow the attacker to inject arbitrary commands that would then be executed in a restricted container with root privileges. To exploit this vulnerability, the attacker must have valid credentials for a user account with at least the role of Observer.
Affected products
- Cisco Digital Network Architecture Center (DNA Center): before 2.3.7.10 — fixed in 2.3.7.10
How to fix
Upgrade to a fixed version: Cisco Digital Network Architecture Center (DNA Center) 2.3.7.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20349 or the next vulnerability affects your stack