What’s Vulnerable › Vulnerabilities
CVE-2025-20358: Cisco Unified Contact Center Express Editor Authentication Bypass Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-05 · updated 2026-10-18
- Weakness: CWE-306
Description
A vulnerability in the Contact Center Express (CCX) Editor application of Cisco Unified CCX could allow an unauthenticated, remote attacker to bypass authentication and obtain administrative permissions pertaining to script creation and execution. This vulnerability is due to improper authentication mechanisms in the communication between the CCX Editor and an affected Unified CCX server. An attacker could exploit this vulnerability by redirecting the authentication flow to a malicious server and tricking the CCX Editor into believing the authentication was successful. A successful exploit could allow the attacker to create and execute arbitrary scripts on the underlying operating system of an affected Unified CCX server, as an internal non-root user account.
Affected products
- Cisco Unified Contact Center Express: before 12.5\(1\)_su03_es07; 15.0 — fixed in 12.5\(1\)_su03_es07
How to fix
Upgrade to a fixed version: Cisco Unified Contact Center Express 12.5\(1\)_su03_es07. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20358 or the next vulnerability affects your stack