What’s Vulnerable › Vulnerabilities
CVE-2025-20363
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-25 · updated 2026-10-18
- Weakness: CWE-122
Description
A vulnerability in the web services of Cisco Secure Firewall Adaptive Security Appliance (ASA) Software, Cisco Secure Firewall Threat Defense (FTD) Software, Cisco IOS Software, Cisco IOS XE Software, and Cisco IOS XR Software could allow an unauthenticated, remote attacker (Cisco ASA and FTD Software) or authenticated, remote attacker (Cisco IOS, IOS XE, and IOS XR Software) with low user privileges to execute arbitrary code on an affected device. This vulnerability is due to improper validation of user-supplied input in HTTP requests. An attacker could exploit this vulnerability by sending crafted HTTP requests to a targeted web service on an affected device after obtaining additional information about the system, overcoming exploit mitigations, or both. A successful exploit could allow the attacker to execute arbitrary code as root, which may lead to the complete compromise of the affected device. For more information about this vulnerability, see the Details ["#details"] section of this advisory.
Affected products
- Cisco ASA Software: from 9.12 before 9.12.4.72; from 9.14 before 9.14.4.28; from 9.16 before 9.16.4.84; from 9.17.1 before 9.18.4.57; from 9.19.1 before 9.19.1.42; from 9.20.1 before 9.20.3.16 — fixed in 9.12.4.72, 9.14.4.28, 9.16.4.84, 9.18.4.57, 9.19.1.42, 9.20.3.16
- Cisco IOS: from 12.2\(15\)b through 15.9\(3\)m11
- Cisco IOS XE: from 3.2.0sg through 17.17.1
- Cisco IOS XR Software: 6.5.1, 6.5.2, 6.5.3, 6.6.2, 6.6.3, 6.6.25 (+7)
- Cisco Firepower Threat Defense Software: from 7.0.0 before 7.0.8; from 7.1.0 before 7.2.10; from 7.3.0 before 7.4.2.3; from 7.7.0 before 7.7.10; 7.6.0 — fixed in 7.0.8, 7.2.10, 7.4.2.3, 7.7.10
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.12.4.72, 9.14.4.28, 9.16.4.84, 9.18.4.57; Cisco Firepower Threat Defense Software 7.0.8, 7.2.10, 7.4.2.3, 7.7.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20363 or the next vulnerability affects your stack