What’s Vulnerable › Vulnerabilities

CVE-2025-20367: Reflected Cross-site Scripting (XSS) in '/app/search/table' endpoint through the 'dataset.command' parameter on Splunk Enterprise

Description

In Splunk Enterprise versions below 9.4.4, 9.3.6 and 9.2.8, and Splunk Cloud Platform versions below 9.3.2411.109, 9.3.2408.119 and 9.2.2406.122, a low-privileged user that does not hold the 'admin' or 'power' Splunk roles could craft a malicious payload through the `dataset.command` parameter of the `/app/search/table` endpoint, which could result in execution of unauthorized JavaScript code in the browser of a user.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.2.8, 9.3.6, 9.4.4; Splunk Cloud Platform 9.2.2406.122, 9.3.2408.119, 9.3.2411.109. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-20367 or the next vulnerability affects your stack