What’s Vulnerable › Vulnerabilities

CVE-2025-20368: Stored Cross-Site Scripting (XSS) through missing field warning messages in Saved Search and Job Inspector on Splunk Enterprise

Description

In Splunk Enterprise versions below 9.4.4, 9.3.6, and 9.2.8, and Splunk Cloud Platform versions below 9.3.2411.108, 9.3.2408.118 and 9.2.2406.123, a low privileged user that does not hold the admin or power Splunk roles could craft a malicious payload through the error messages and job inspection details of a saved search. This could result in execution of unauthorized JavaScript code in the browser of a user.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.2.8, 9.3.6, 9.4.4; Splunk Cloud Platform 9.2.2406.123, 9.3.2408.118, 9.3.2411.108. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-20368 or the next vulnerability affects your stack