What’s Vulnerable › Vulnerabilities
CVE-2025-20370: Denial of Service (DoS) through Multiple LDAP Bind Requests in Splunk Enterprise
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-10-18
- Weakness: CWE-400
Description
In Splunk Enterprise versions below 10.0.1, 9.4.4, 9.3.6, and 9.2.8, and Splunk Cloud Platform versions below 9.3.2411.108, 9.3.2408.118 and 9.2.2406.123, a user who holds a role that contains the high-privilege capability `change_authentication`, could send multiple LDAP bind requests to a specific internal endpoint, resulting in high server CPU usage, which could potentially lead to a denial of service (DoS) until the Splunk Enterprise instance is restarted. See https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.0/manage-splunk-platform-users-and-roles/define-roles-on-the-splunk-platform-with-capabilities and https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.0/use-ldap-as-an-authentication-scheme/configure-ldap-with-splunk-web#cfe47e31_007f_460d_8b3d_8505ffc3f0dd__Configure_LDAP_with_Splunk_Web for more information.
Affected products
- Splunk Enterprise: from 9.2.0 before 9.2.8; from 9.3.0 before 9.3.6; from 9.4.0 before 9.4.4; 10.0.0 — fixed in 9.2.8, 9.3.6, 9.4.4
- Splunk Cloud Platform: from 9.2.2406 before 9.2.2406.123; from 9.3.2408 before 9.3.2408.118; from 9.3.2411 before 9.3.2411.108 — fixed in 9.2.2406.123, 9.3.2408.118, 9.3.2411.108
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.2.8, 9.3.6, 9.4.4; Splunk Cloud Platform 9.2.2406.123, 9.3.2408.118, 9.3.2411.108. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20370 or the next vulnerability affects your stack