What’s Vulnerable › Vulnerabilities

CVE-2025-20371: Unauthenticated Blind Server Side Request Forgery (SSRF) in Splunk Enterprise

Description

In Splunk Enterprise versions below 10.0.1, 9.4.4, 9.3.6 and 9.2.8, and Splunk Cloud Platform versions below 9.3.2411.109, 9.3.2408.119 and 9.2.2406.122, an unauthenticated attacker could trigger a blind server-side request forgery (SSRF) potentially letting an attacker perform REST API calls on behalf of an authenticated high-privileged user.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.2.8, 9.3.6, 9.4.4; Splunk Cloud Platform 9.2.2406.122, 9.3.2408.119, 9.3.2411.109. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-20371 or the next vulnerability affects your stack