What’s Vulnerable › Vulnerabilities
CVE-2025-20376: Cisco Unified Contact Center Express Remote Code Execution Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-05 · updated 2026-10-18
- Weakness: CWE-434
Description
A vulnerability in the web UI of Cisco Unified CCX could allow an authenticated, remote attacker to upload and execute arbitrary files. This vulnerability is due to an insufficient input validation associated to file upload mechanisms. An attacker could exploit this vulnerability by uploading a malicious file to the web UI and executing it. A successful exploit could allow the attacker to execute arbitrary commands on the underlying system and elevate privileges to root. To exploit this vulnerability, the attacker must have valid administrative credentials.
Affected products
- Cisco Unified Contact Center Express: before 12.5\(1\)_su03_es07; 15.0 — fixed in 12.5\(1\)_su03_es07
How to fix
Upgrade to a fixed version: Cisco Unified Contact Center Express 12.5\(1\)_su03_es07. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-20376 or the next vulnerability affects your stack