What’s Vulnerable › Vulnerabilities

CVE-2025-20384: Unauthenticated Log Injection in Splunk Enterprise

Description

In Splunk Enterprise versions below 10.0.1, 9.4.6, 9.3.8, and 9.2.10, and Splunk Cloud Platform versions below 10.1.2507.4, 10.0.2503.6, and 9.3.2411.117.125, an unauthenticated attacker can inject American National Standards Institute (ANSI) escape codes into Splunk log files due to improper validation at the /en-US/static/ web endpoint. This may allow them to poison, forge, or obfuscate sensitive log data through specially crafted HTTP requests, potentially impacting log integrity and detection capabilities.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.2.10, 9.3.8, 9.4.6; Splunk Cloud Platform 10.0.2503.6, 10.1.2507.4, 9.3.2411.117. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-20384 or the next vulnerability affects your stack