What’s Vulnerable › Vulnerabilities

CVE-2025-20389: Improper Input Validation in "label" column field in Splunk Secure Gateway App

Description

In Splunk Enterprise versions below 10.0.2, 9.4.6, 9.3.8, and 9.2.10, and versions below 3.9.10, 3.8.58 and 3.7.28 of the Splunk Secure Gateway app on Splunk Cloud Platform, a low-privileged user that does not hold the "admin" or "power" Splunk roles could craft a malicious payload through the `label` column field after adding a new device in the Splunk Secure Gateway app. This could potentially lead to a client-side denial of service (DoS).

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 10.0.2, 9.2.10, 9.3.8, 9.4.6; Splunk Cloud Platform 10.0.2503.8, 10.1.2507.6, 9.3.2411.120; Splunk Secure Gateway 3.7.28, 3.8.58, 3.9.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-20389 or the next vulnerability affects your stack