What’s Vulnerable › Vulnerabilities

CVE-2025-2045: Incorrect Authorization in GitLab

Description

Improper authorization in GitLab EE affecting all versions from 17.7 prior to 17.7.6, 17.8 prior to 17.8.4, 17.9 prior to 17.9.1 allow users with limited permissions to access to potentially sensitive project analytics data.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.7.6, 17.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2045 or the next vulnerability affects your stack