What’s Vulnerable › Vulnerabilities
CVE-2025-2055: MapPress Maps for WordPress < 2.94.9 - Contributor+ Stored XSS
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The MapPress Maps for WordPress plugin before 2.94.9 does not sanitise and escape some parameters when outputing them in the page, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks.
Affected products
- MapPress Maps for WordPress: before 2.94.9 — fixed in 2.94.9
How to fix
Upgrade to a fixed version: MapPress Maps for WordPress 2.94.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2055 or the next vulnerability affects your stack