What’s Vulnerable › Vulnerabilities
CVE-2025-2056: WP Ghost <= 5.4.01 - Unauthenticated Limited File Read
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-14 · updated 2026-06-17
- Weakness: CWE-23
Description
The WP Ghost (Hide My WP Ghost) – Security & Firewall plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 5.4.01 via the showFile function. This makes it possible for unauthenticated attackers to read the contents of specific file types on the server, which can contain sensitive information.
Affected products
- johndarrel WP Ghost (Hide My WP Ghost) – Security & Firewall: before 5.4.02 — fixed in 5.4.02
How to fix
Upgrade to a fixed version: johndarrel WP Ghost (Hide My WP Ghost) – Security & Firewall 5.4.02. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/hide-my-wp/tags/5.4.02/models/Files.php#L336
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f43db496-80ea-442c-9417-7aa03ec95f02?source=cve
Get alerted when CVE-2025-2056 or the next vulnerability affects your stack