What’s Vulnerable › Vulnerabilities
CVE-2025-2075: Uncanny Automator <= 6.3.0.2 - Missing Authorization to Authenticated (Subscriber+) Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-04 · updated 2026-06-17
- Weakness: CWE-862
Description
The Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 6.3.0.2. This is due to add_role() and user_role() functions missing proper capability checks performed through the validate_rest_call() function. This makes it possible for unauthenticated attackers to set the role of arbitrary users to administrator granting full access to the site, though privilege escalation requires an active account on the site so this is considered an authenticated privilege escalation.
Affected products
- uncannyowl Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin: before 6.4 — fixed in 6.4
How to fix
Upgrade to a fixed version: uncannyowl Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin 6.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3257300/uncanny-automator/trunk/src/core/classes/class-background-actions.php
- https://plugins.trac.wordpress.org/changeset/3265280/uncanny-automator/trunk/src/core/classes/class-background-actions.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/86b4b0d6-bda2-47f3-a0b5-9733cb7a11f6?source=cve
Get alerted when CVE-2025-2075 or the next vulnerability affects your stack