What’s Vulnerable › Vulnerabilities

CVE-2025-2103: SoundRise Music <= 1.7 - Authenticated (Subscriber+) Arbitrary Options Update

Description

The SoundRise Music plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on theironMusic_ajax() function in all versions up to, and including, 1.6.11. This makes it possible for authenticated attackers, with subscriber-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.

Affected products

How to fix

Upgrade to a fixed version: IronTemplates SoundRise Music 1.7.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2103 or the next vulnerability affects your stack